Products & Solutions  Resources  Support  Training & Services  About
US/Canadian Site 

Rocket BusinessConnect

Alert: BDT versions 1.2.2 and 1.2.3 - Dictionary Editor Corrupts Data in Pick Accounts

In Basic Developer Toolkit (BDT) version 1.2.2 and 1.2.3, if you are connected to a Pick-flavored account, saving dictionary records using the dictionary editor will corrupt the dictionary.

The BDT tool incorrectly reads Pick-type dictionary records, and then saves the incorrect records back to the server. This problem impacts connections to both UniVerse and UniData.

The 1.2.2 version was included with the UniVerse 11.1.0 Clients. The 1.2.3 version was only available via the Early Access Program.

This problem is addressed in the BDT version 1.2.4 released later this month (April 2011).

BDT versions 1.2.1 and earlier are not impacted by this problem. If you are using BDT version 1.2.2 or 1.2.3, do not use the dictionary editor.